Corrupted TLog backups after started using HperBac

Silent compression for faster, smaller SQL Server backups

Moderators: eddie davis, Colin Millerchip, fionag

Corrupted TLog backups after started using HperBac

Postby nawarrick » Wed Oct 06, 2010 11:34 pm

Hi,

We're using SQL HyperBac 5 to speed up log shipping. We have it configured to compress transaction log backups in Dallas and ship them to Virginia.

Once a week there's a bulk operation that causes a large TLog backup of about 1 GB in compressed size - 4 GB uncompressed. Since we started using Hyperbac, the restore of this file would occasionally fail on the secondary server in Virginia with the following error:

2010-10-04 09:32:00.55 *** Error: The volume on device 'C:\\SQLLogs_LS\\dbname_20101004081001.trn' is empty.

Once the same file is recopied from Dallas, all is well. It happened twice in the past 2 months, so it does not occur often. The files are the same size in Dallas and Virginia. HyperUtil.exe returns CRC: 0x0, and a manual restore of the same file via t-sql outputs the same error.

What could be causing this problem?

-Nigel
nawarrick
 
Posts: 6
Joined: Thu Jul 15, 2010 9:39 pm
Location: NY

Postby javen » Thu Oct 07, 2010 5:36 am

Hi, what version of SQL HyperBac are you running on the primary and standby nodes of the log shipping pair respectively?
Jeffrey Aven
Product Management - HyperBac Technologies
Red Gate Software
javen
 
Posts: 50
Joined: Tue May 25, 2010 12:10 am

Postby nawarrick » Thu Oct 07, 2010 2:45 pm

Hi,

The primary server has HyperBac 5.0.8.0, and the secondary server has version 4.3.0.0 installed.
nawarrick
 
Posts: 6
Joined: Thu Jul 15, 2010 9:39 pm
Location: NY

Postby javen » Fri Oct 08, 2010 12:19 am

Are you able to update both nodes to 5.0.38, note that the node on 4.x (standby node) will require a reboot to complete the upgrade and will also require a serial number for licensing (which can be obtained from the sales team, unless it is a restore only node). This should avert this issue from occurring.
Jeffrey Aven
Product Management - HyperBac Technologies
Red Gate Software
javen
 
Posts: 50
Joined: Tue May 25, 2010 12:10 am

Postby nawarrick » Fri Oct 08, 2010 9:58 pm

We'll give this a try and let you know. Thanks for your help.
nawarrick
 
Posts: 6
Joined: Thu Jul 15, 2010 9:39 pm
Location: NY

Postby nawarrick » Mon Nov 22, 2010 6:22 pm

Hi,

We upgrade both servers to 5.0.38 and the issue occurred once again this morning. It took a while to reoccur because we haven't had a very large transaction log backup for a while. Sine we upgraded, the backups on Mondays were about 400 to 500 MB compressed. The backup this morning was 1.3 GB compressed, which turned out to be over 5 GB uncompressed.

Is there anything else we can try? Have others reported this issue?
nawarrick
 
Posts: 6
Joined: Thu Jul 15, 2010 9:39 pm
Location: NY

Postby eddie davis » Wed Dec 01, 2010 7:32 pm

Thank you for your reply.

To investigate this problem in more detail, can we please obtain all the HyperBac log files located in the HyperBac Logs folder? Please send the requested log files to support@red-gate.com and include your contact details so we can create a support call for you.

In the period that since you were first requested to upgrade to HyperBac V5.0.38, Version 5.1 has now been released. If you wish to upgrade to this newer version of HyperBac to see if the problem is resolved in this version, please use the following LINK. Select the correct installer for your system 32-bit or 64-bit.

Many Thanks
Eddie
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
eddie davis
 
Posts: 942
Joined: Wed Jun 14, 2006 3:47 pm
Location: Red Gate Software


Return to SQL HyperBac 5

Who is online

Users browsing this forum: No registered users and 0 guests