Profiled application closes when login screen closes

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Profiled application closes when login screen closes

Postby bkwilliams10 » Wed Sep 22, 2010 8:40 pm

My application has a login screen. When I launch the profiler and point it at my application, it runs fine until the login screen closes. The main form shows for a moment, but then the entire application closes. Is there a different way that I need to launch the application so I can profile the entire thing (rather than just the application start/first start process)? Any help would be appreciated.
Brian Williams
bkwilliams10
 
Posts: 1
Joined: Wed Sep 22, 2010 8:15 pm
Location: Corvallis, OR

Postby nick.maidment » Thu Sep 23, 2010 11:08 am

I assume from your description that your application launches multiple processes and that you've left "Profile child processes" ticked. Does the initial process shutdown after you've logged in?

What version of .net are you compiled against? if you can compile against .net 4 then you should be able to use the "attach to .net 4 process" option to capture the information you require.

If you're still having trouble, you can get in touch with support @ red-gate . com with F0039339 in the subject line for more in depth investigation.
nick.maidment
 
Posts: 74
Joined: Fri Jan 29, 2010 1:55 pm


Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 1 guest