Unable to profile WCF within Visual Studio

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Unable to profile WCF within Visual Studio

Postby pareshkoyani@gmail.com » Tue Sep 21, 2010 1:07 am

Hi,

I just started to use profiling tool but do not able to do profiling on wcf service which is hosted within visual studio.

even tool does not enable start profiling button for me nor giving any error message..

i tried to search videos and article but no help...

I would really appreciate your help on this.
pareshkoyani@gmail.com
 
Posts: 2
Joined: Tue Sep 21, 2010 1:04 am

Postby Brian Donahue » Tue Sep 21, 2010 4:04 pm

Hello Paresh,

I would say that either the ANTS Profiler add-in is not responding or it hasn't detected a valid project. You can try resetting the add-in:


1. Export your current VS settings into a file via Tools->Import And Export Settings
2. Choose the Visual Studio command prompt tool from the start menu, under the Visual Studio program group.
3. Execute the following commands:

>devenv /resetsettings
>regasm /codebase "%programfiles%\\red gate\\ants performance profiler 6\\RedGate.Profiler.Five.AddIn.dll"
>regasm /codebase "%programfiles%\\red gate\\ants memory profiler 6\\RedGate.Memory.AddIn.dll"

[You may get a warning here which is safe to ignore but you should finally get the message: "Types registered successfully"]

>devenv /setup

Now your add-in should be re-initilaized. Ensure you have a ready-to-run project loaded into VS and the addin integration should work now.

4. Import your saved settings via Tools->Import And Export Settings

Note that it is not necessary to profile using the Visual Studio add-in -- you can launch ANTS Performance Profiler 6 from the start menu and choose the "ASP .NET web application hosted in the development webserver" option as well.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby pareshkoyani@gmail.com » Tue Sep 21, 2010 6:07 pm

Hi Brian,

Thanks for quick reply,

I did try to reset add-in but I could not find RedGate.Profiler.Five.AddIn.dll and RedGate.Memory.AddIn.dll at

C:\\Program Files\\Red Gate\\ANTS Performance Profiler 6
C:\\Program Files\\Red Gate\\ANTS Memory Profiler 6

I have installed bundle package of trail version.

Thanks,
Paresh
pareshkoyani@gmail.com
 
Posts: 2
Joined: Tue Sep 21, 2010 1:04 am

Postby Brian Donahue » Wed Sep 22, 2010 9:37 am

Hi Paresh,

What menu items are grayed out? All of them? You should always be able to launch memory and performance profilers, event if no project is loaded.

As of v6, the add-in has moved to %programfiles%\\red gate\\ants profiler visual studio add-in 1\\RedGate.ANTSVsAddin.addin. Sorry for the confusion -- our internal docs are out-of-date.

Also as of v6, the add-in moved out of the performance and memory profiler installers and into the .NET developer bundle installer. But if this is the first time you have used Performance Profiler, this shouldn't be an issue because the evaluation should be the .net bundle installer.

But you can try fixing this as before but changing the add-in location:
regasm /codebase " %programfiles%\\red gate\\ants profiler visual studio add-in 1\\RedGate.ANTSVsAddin.dll"
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 1 guest