SQL Server 2005 Processes SLOOOOW

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Moderators: Chris Auckland, David Atkinson, sherr, PhilScrace

SQL Server 2005 Processes SLOOOOW

Postby sspratlen » Fri Jul 16, 2010 3:04 pm

We just implemented using SQL Source Control 1.0.1.13 on our SQL 2005 Servers. Most of our DB's use 2000 Compatability.

We found that alot of processes are running from Red Gate doing multiple drops and select constantly, causing massive slow downs.

If we close SQL Studio and restart everything is fine for a short time, then it starts running drops and select again, utilizing large chunks of CPU time.

I am seeing these in sp_who2 active to verify that it is the Red Gate processes.

Any ideas? I really like the source control functionality, but I would hate to uninstall because I cannot have it slow other processes down to a crawl.

Thanks,
Scott
sspratlen
 
Posts: 1
Joined: Fri Jul 16, 2010 2:52 pm

SQL Server 2005 Processes SLOOOOW

Postby sherr » Tue Jul 20, 2010 8:46 pm

Hello Scott,

Our internal reference number is SOC-1334. We will follow up with you directly via email to get some more information about your system and try to work through this issue.

Thank you!
Stephanie M. Herr :-)
SQL Source Control Project Manager
sherr
 
Posts: 126
Joined: Thu Mar 19, 2009 12:45 pm
Location: Cambridge

Postby BjarneC » Thu Aug 12, 2010 12:45 pm

Did you find any solution for this, as I am currently expiriencing similar behaviour ?
/Bjarne
BjarneC
 
Posts: 1
Joined: Thu Aug 12, 2010 12:20 pm
Location: Denmark

Postby mamueller » Thu Sep 02, 2010 11:31 am

Hello!

Is there any news about this issue?

Started using the tool as well, but are also experiencing the DB Load issue, which causes problems in our Dev Environment.

We´re using a Shared Dev DB, maybe thats the issue ?

thx
cheers
mamueller
 
Posts: 1
Joined: Tue Aug 31, 2010 8:45 am

Postby Chris Auckland » Mon Dec 06, 2010 9:14 pm

Sorry for the slow reply.

We're still looking into performance improvments for SQL Source Control, but I can give you a workaround which might help you in the mean time.

The workaround is to disable the code that polls your database. This will mean that the blue indicators in the Object Explorer are often out of date, but it should reduce the load on your database server to acceptable levels.

To apply the workaround, you will need to edit the 'RedGate_SQLSourceControl_Engine_EngineOptions' in your SQL Source Control configuration directory. This is either: C:\\Users\\<username>\\AppData\\Local\\Red Gate\\SQL Source Control 1 or C:\\Documents and Settings\\<username>\\Local Settings\\Application Data\\Red Gate\\SQL Source Control 1 depending on your operating system version.

The following XML is an example of setting the polling frequency to '0'. This will mean that SQL Source control will not check for changes, but you can still manually perform the check if you hit 'refresh'. You might want to try different values between 0 and the defaults, until you have an acceptable performance.

Code: Select all
<?xml version="1.0" encoding="utf-16" standalone="yes"?><!----><EngineOptions version="2" type="EngineOptions"><DefaultTraceMinimumInterQueryTimeInMillis>0</DefaultTraceMinimumInterQueryTimeInMillis><SysObjectsMinimumInterQueryTimeInMillis>0</SysObjectsMinimumInterQueryTimeInMillis><SysTypesMinimumInterQueryTimeInMillis>0</SysTypesMinimumInterQueryTimeInMillis><DefaultTraceMinimumRequestedInterQueryTimeInMillis>0</DefaultTraceMinimumRequestedInterQueryTimeInMillis></EngineOptions>


THE v1 DEFAULT VALUES ARE:
25000 DefaultTraceMinimumInterQueryTimeInMillis
2500 SysObjectsMinimumInterQueryTimeInMillis
3500 SysTypesMinimumInterQueryTimeInMillis
5000 DefaultTraceMinimumRequestedInterQueryTimeInMillis

I hope this helps.
Chris
Chris Auckland
 
Posts: 757
Joined: Tue Oct 24, 2006 2:12 pm
Location: Red Gate Software Ltd.


Return to SQL Source Control 1

Who is online

Users browsing this forum: No registered users and 1 guest