Logging

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, Alex.Davies, melvyn.harbour

Logging

Postby CSXPJC » Fri Aug 27, 2010 11:23 am

Does SmartAssembly generate any logging information? I am unable to find a log file, or see anything in the Windows eventlog.

I am trying to diagnose a problem whereby some projects don't write their builds to the database or generate obfuscation maps, and the message shown in the UI after building doesn't give any clues.
CSXPJC
 
Posts: 4
Joined: Fri Aug 27, 2010 11:18 am

Postby slaphead99 » Mon Aug 30, 2010 12:49 pm

Just a quick check- are you selecting the "Mark as Released!" option for these project builds?
slaphead99
 
Posts: 92
Joined: Wed Mar 10, 2010 2:27 pm

Postby CSXPJC » Tue Aug 31, 2010 9:15 am

No, I am not marking either the project that is being logged to the database or the projects that aren't as released builds. I am currently just using the UI to perform the build.

It might be worth noting that I initially installed SA as a trial and modified the SA settings file to use a different database connection string. I then created the project that is currently working and built that a few times. I then activated my SA licence and tried creating some new projects but these are not being added to the 'Projects' table of the database and builds are not being placed in the 'Builds' table. I can however still build the original working project fine and see entries going into the 'Builds' table for that project.
CSXPJC
 
Posts: 4
Joined: Fri Aug 27, 2010 11:18 am


Return to SmartAssembly 5

Who is online

Users browsing this forum: No registered users and 0 guests