Exception reports being deleted

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, Alex.Davies, melvyn.harbour

Exception reports being deleted

Postby Uniwares_AS » Wed Aug 11, 2010 1:47 am

It just happened to me that I lost a few exception reports from an older application which was created with a previous version of SA on another machine.
SA5 downloaded the report, told me that this report was not created on this machine and then deleted it from the server.

Not exactly as I would imagine this to happen. I still might want to get the reports from another machine where the app was originally built, or where the database is available.
Uniwares_AS
 
Posts: 132
Joined: Thu Oct 11, 2007 3:29 pm

Postby nick.maidment » Fri Aug 13, 2010 2:47 pm

Assuming the reports made it into your database ok, you should be able to use the sdk database example (found in your installation folder) to retrieve them. Let me know how you get on.
nick.maidment
 
Posts: 74
Joined: Fri Jan 29, 2010 1:55 pm

Postby Uniwares_AS » Fri Aug 13, 2010 2:50 pm

Should they be in the database? As I understood the message (don't remember the precise wording now) SA didn't save the report because the database didn't contain information about this specific application.

If they are, how do I transfer them to the machine where the app was built?
Uniwares_AS
 
Posts: 132
Joined: Thu Oct 11, 2007 3:29 pm

Postby Alex.Davies » Mon Aug 16, 2010 11:50 am

When the map file is missing, SA should place the .saencryptedreport file somewhere on your computer in case you want it again.

In windows xp/2003 it puts it in program files, in SmartAssembly's folder.

In windows vista and above, it puts in in ProgramData, again in SmartAssembly's folder.

You can just double click these (on a machine which does have the appropriate map file) to open them.
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk

Postby Uniwares_AS » Mon Aug 16, 2010 10:16 pm

Ok Alex, this was the missing piece of information. The files are exactly where you said.

This should be part of the error message, could even place a link in it to open the folder where they are saved.

Thanks. Solved.
Uniwares_AS
 
Posts: 132
Joined: Thu Oct 11, 2007 3:29 pm


Return to SmartAssembly 5

Who is online

Users browsing this forum: No registered users and 0 guests