Can not see source code pane (winforms profiling)

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Can not see source code pane (winforms profiling)

Postby spallison » Wed Aug 11, 2010 4:26 pm

I just installed a trial package, so this is an unlicensed trial question.

At first, I could see the source code panel. Then I rebuilt all my source. Now, none of the methods in the profile will show any source. It is as if the source code panel was turned off, and it refuses to show.

I checked my start up projects bin\\debug folder and all the pdb files are there and perfectly match the dll files for time of build.

When I try to use the View->Show source view, it is neither bolded nor do I get any response whatsoever. I really want to see the break down in the methods.

This software shows real promise to focus me to exactly where my performance issues are and I'm excited to get use out of it, and try to get a purchase approved.

But I'd really like to see the source again at it was showing earlier this day.
spallison
 
Posts: 2
Joined: Wed Aug 11, 2010 4:16 pm

Postby SharedProphet » Wed Aug 11, 2010 5:13 pm

I had the same problem, with the full version. Solution is here:
http://www.red-gate.com/MessageBoard/vi ... hp?p=41870
SharedProphet
 
Posts: 3
Joined: Tue Aug 10, 2010 7:50 pm

Postby spallison » Wed Aug 11, 2010 5:26 pm

Thank you shared prophet that did the trick.

To be explicit, I simply did the following:

Delete all the registry entries in:
HKEY_CURRENT_USER\\Software\\Red Gate\\ANTS Performance Profiler 6\\Dock States\\
spallison
 
Posts: 2
Joined: Wed Aug 11, 2010 4:16 pm

Postby StephenC » Wed Aug 11, 2010 9:54 pm

Thanks SharedProphet,

nice to see you are helping users out on the forums for us. The tech support team are very happy and have asked if you can stick around for longer?
:D

Just to clarify on this issue - there's a bug of some sort in the docking component being used to display the windows. We cannot appear to work around it from within the ANTS UI and the only solution so far is to manually delete the registry keys.

Regards,

Stephen
StephenC
 
Posts: 306
Joined: Mon Oct 15, 2007 9:18 am
Location: Cambridge


Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 0 guests