Licensing for SA v5

Early Access Program for SmartAssembly

Moderators: Luke Jefferson, JasonC, StephenC, Alex.Davies, melvyn.harbour, GrahamH, Simon C

Licensing for SA v5

Postby rs » Wed May 12, 2010 10:21 am

Hello,

We have a v4 license (client, build server, custom web server). Can you clarify if we are licensed to use v5 - we have an outstanding issue with missing exception report stack frames in v4 and v5 gives us a partial solution to that so I'm wondering if we can press ahead with implementing v5. With v4 we had a license file we needed to copy in order to avoid errors when distributing the obfuscated assemblies - is there something similar we need to do with v5?

Thanks for the help, and for pushing forward with this simply superb product.

RS
rs
 
Posts: 11
Joined: Wed May 12, 2010 10:18 am

Anybody there?

Postby rs » Fri May 14, 2010 12:48 pm

Could I please get a response on this one - we're seeing licensing errors when reporting exceptions to our custom web server with the v5 trial, so I'm pretty sure we need to activate / get a serial somehow. We do have a current SA maintenance plan in place.
rs
 
Posts: 11
Joined: Wed May 12, 2010 10:18 am

Postby Alex.Davies » Fri May 14, 2010 5:58 pm

Yes, the maintenance plan will allow you to upgrade to V5 for no extra cost. You'll need to contact sales when v5 is released to get a V5 serial number. There won't be a license file anymore, the serial number will do its job.

I'll look into the trial web service right now, it should be working normally, thanks for the report.

Cheers,
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk

Postby rs » Fri May 14, 2010 6:03 pm

Thanks for the reply. The problem is that we use a custom web service (hosted on our own site). This works fine with v4, but I get a license error when trying to report an error from an app built with SA v5. I'm guessing this is down to not having a licensed client. Is there a way around that - we're keen to use v5 to get around our missing stack frames bug with v4.
rs
 
Posts: 11
Joined: Wed May 12, 2010 10:18 am

Postby Alex.Davies » Mon May 17, 2010 9:45 am

We hadn't released the custom web service for v5 (they're incompatible).

Here it is:
http://downloads.red-gate.com/EAP/Smart ... ervice.zip

I hope you'll be able to work out how to use it, it's more or less the same as the old one.

Cheers,
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk

Postby rs » Tue May 18, 2010 10:59 am

Many thanks for posting the web service. I've installed this ok on our web server and configured SmartAssembly to use it. One observation - I needed to add a trailing / character to the web service url in the SmartAssembly client settings to avoid an error when trying to report.

I can't seem to download reports from the web service though - I get an error "ERROR: Failed to non-securely login to web service (Bad Login Key)".

Is there a way for us to get a license key for the EAP, so we can start ramping up / validating the end to end process in readiness for the release version?
rs
 
Posts: 11
Joined: Wed May 12, 2010 10:18 am

Postby Alex.Davies » Tue May 18, 2010 11:13 am

Thanks for the report about the trailing slash, I'll definitely make that optional.

You need to configure who has access to the web service in the web.config to make it work. You might find it hard without having a serial number. Perhaps I should make it allow everything by default.
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk

Postby rs » Tue May 18, 2010 11:14 am

Restricting to reports from the assemblies we build certainly makes sense. Only problem is we don't have a serial as yet. Can we have one - pretty please :)
rs
 
Posts: 11
Joined: Wed May 12, 2010 10:18 am

Postby Alex.Davies » Wed May 19, 2010 12:06 pm

The new build of the custom web server now accepts all users by default.
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk


Return to SmartAssembly EAP

Who is online

Users browsing this forum: No registered users and 1 guest