BUG: strange results with .

A free Management Studio add-in to search for SQL in your databases

Moderators: JonathanWatts, David Atkinson, Anu Deshpande, Paul Stephenson, Michelle Taylor, Mike Upton, Adam, justin.caldicott

BUG: strange results with .

Postby emoreau » Tue Feb 02, 2010 3:10 pm

if you type "a.b" (without the quotes), the list of results is filled with many items but non are relevant and nothing is highligthed.

In fact, I was looking for something like "dbo.UP_" and got strange results.

Apparently the . is messing up things.
emoreau
 
Posts: 38
Joined: Tue May 23, 2006 6:48 pm

dot (.) creates strange results

Postby erwino » Mon Feb 08, 2010 12:33 pm

We are experiencing the same behaviour, if you search for xxx.dbo.tablename the results are not as expected until you remove the xxx.dbo. Makes it much harder to find references to another db.
semper in excretia sumus solum profundum variat
erwino
 
Posts: 2
Joined: Mon Feb 08, 2010 12:29 pm

Postby tanya » Mon Feb 08, 2010 5:13 pm

Hi,

Apologies for the inconvenience this is causing.
SQL Search currently ignores dot and so the issue. We are looking into addressing this soon.
I will keep the forum posted and thanks for your patience.

Regards,
Tanya
Project Manager
Red Gate Software Ltd
tanya
 
Posts: 252
Joined: Mon Apr 30, 2007 8:29 pm

Postby tkdennis » Thu Mar 04, 2010 6:41 pm

I was wondering why SQL Search was giving me false positives. Having the "." is critical when working with schemas. Is there an ETA on a patch for this?

Thanks,
Traci
tkdennis
 
Posts: 75
Joined: Fri Feb 29, 2008 1:13 am

Postby tkdennis » Thu Mar 11, 2010 5:05 am

Our databases use schemas extensively. Searching for schema.object is producing many invalid hits because SQL Search is ignoring the dot. Is there a patch coming for this anytime soon?

Thanks,
Traci
tkdennis
 
Posts: 75
Joined: Fri Feb 29, 2008 1:13 am

Postby tanya » Thu Mar 11, 2010 11:30 am

Hi Traci,

We do not have any dates on this as yet but this issue (SDI-128) is very high on our list and we are looking into working on this soon.
I will keep the forum posted with updates on this.

Thanks,
Tanya
Project Manager
Red Gate Software Ltd
tanya
 
Posts: 252
Joined: Mon Apr 30, 2007 8:29 pm

Postby David Atkinson » Wed May 19, 2010 5:29 pm

The behavior should be much improved now. Please download the latest build and let us know how you get on.

http://www.red-gate.com/MessageBoard/vi ... hp?t=11125

Kind regards,

David
David Atkinson
 
Posts: 1124
Joined: Mon Dec 05, 2005 4:54 pm
Location: Twitter: @dtabase

Postby sergio » Wed Mar 16, 2011 8:50 pm

David,

After reading your note, I downloaded the latest build (1.0.0.321) but it still behaves as described in previous posts. It does not give me all the search results. I am using SQL Server 2008 SP2 Developer edition.


Regards,

Srdjan
sergio
 
Posts: 1
Joined: Wed Mar 16, 2011 8:15 pm


Return to SQL Search 1

Who is online

Users browsing this forum: No registered users and 2 guests