Can't see the timeline when profiling

Memory profiling for .NET developers

Moderators: StephenC, Alex.Davies, AndrewH, melvyn.harbour

Can't see the timeline when profiling

Postby theoneandonly » Fri Feb 26, 2010 3:30 pm

Hello,

I've got a problem with the "Trial" of ANTS 5.2.0.49 Memory Profiler. If I try profile a windows forms .net app, i can't see the timeline. I can do memory snapshots but the timeline isn't there so I have no overview i the memory has changed (profiling correctly). Please help me.

Greetz from Germany
theoneandonly
 
Posts: 3
Joined: Fri Feb 26, 2010 3:26 pm

Postby StephenC » Fri Feb 26, 2010 3:47 pm

Hi,

take a look at this forum post regarding what should be the same issue:

http://www.red-gate.com/messageboard/vi ... hp?t=10479

If you rebuild the performance counters per the article can you post back and let me know if the solution worked.

Thanks,

Stephen
StephenC
 
Posts: 306
Joined: Mon Oct 15, 2007 9:18 am
Location: Cambridge

Does not work for me

Postby theoneandonly » Mon Mar 01, 2010 2:15 pm

Hi,

thanx for your quick response. But this solution does not work for me. I've done to rebuild the performace counters as described in this article.
But I stuck on the following command:

To rebuild all Performance counters including extensible and third-party counters in Windows Server 2003, type the following commands at a command prompt. Press ENTER after each command.

cd\\windows\\system32

lodctr /R


-> solved by me doing: lodctr /R:*.*

The last statement is not pperformed by me either:
Reinstall any custom .NET Framework assembly performance counters


Cause I don't know which Assemblies create the performance counters? What are your assemblies for creating counters? Could I see those counters in the perf view?

Please help ...

Regards,
Marco
theoneandonly
 
Posts: 3
Joined: Fri Feb 26, 2010 3:26 pm

Postby Brian Donahue » Mon Mar 01, 2010 5:58 pm

Hi Marco,

We have some updated information in the Red Gate KB that includes instructions for reloading the .NET performance counters. Please see:
http://www.red-gate.com/supportcenter/C ... 000316.htm

Thanks!
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

It's working

Postby theoneandonly » Tue Mar 02, 2010 9:44 am

Thanks,

the Knowledge Base article solved my problem. Definitely it was the .NET
"corperfmonsymbols.ini"
. (That should be mentioned first in the article)


Regards,
Marco
theoneandonly
 
Posts: 3
Joined: Fri Feb 26, 2010 3:26 pm

Postby Brian Donahue » Tue Mar 02, 2010 3:10 pm

Great...thanks for the follow-up.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Memory Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests