Possible Server Performance hit

Early Access Program for SQL Source Control

Moderators: Chris Auckland, David Atkinson, sherr

Possible Server Performance hit

Postby tmanhollan » Tue Jan 26, 2010 12:01 am

Haven't spent much time evaluating just yet. First impression of usability is quite positive. Interface is intuitive and the integration with management studio is pretty smooth. I installed this morning, linked up to an existing database and got it dumped into my svn repository. Management studio seemed a little sluggish at times, but my workstation has a lot going on. I got busy with a few other things and management studio got pushed to the side for most of the day.

This afternoon, I noticed that earlier in the day my cpu on the server had jumped substantially. Went over to the activity monitor in management studio and noticed a lot of open connections coming from my workstation with "Red Gate" in the Application column. So I unlinked the database from source control and the cpu on the server dropped back down to normal (usual) level. See graph here. Note, the numbers don't mean a lot on their own--they're averages sampled too infrequently to get an accurate read on actual CPU use. But it illustrates the relative increase and then decrease, which serves my needs in monitoring it.

This is just an observation at this point not a complaint, and it's certainly not a thorough evaluation. The jump corresponds with my connecting the source control and the drop corresponds with my disconnecting it. I'll spend some more time with it when I can, and report any further findings.
tmanhollan
 
Posts: 1
Joined: Mon Jan 25, 2010 11:32 pm
Location: Youngstown, Ohio, USA

Postby fatherjack » Wed Jan 27, 2010 2:28 pm

Yeah, I would say we had a noticable performance hit while I was linked to a database. I got a phone call from a user about it. Its only a test server but they never complain about perf on that normally. The CPU trace was bouncing down from 100 rather than up from 0. I eventually cancelled the SC connection and had an error I have logged elsewhere.
-----------------------------------------
Senior DBA
Careers South West Ltd
fatherjack
 
Posts: 224
Joined: Tue Mar 13, 2007 12:33 pm
Location: Cornwall

CPU Performance Issues

Postby sherr » Thu Feb 04, 2010 8:12 pm

We are currently working performance issues and hope to have some improvements in the next early access release. In the meantime, if this is stopping you from evaluating SQL Source Control, there is a workaround that you can do to fix this CPU performance hit. Please email SqlSourceControlSupport@red-gate.com for specific details.
sherr
 
Posts: 126
Joined: Thu Mar 19, 2009 12:45 pm
Location: Cambridge

Slowed our server to a crawl - had to uninstall it

Postby harvest316 » Tue Mar 09, 2010 6:58 am

I might have gotten a little over-excited but I put 15 databases on our 2008 dev server under source control, then got a workmate to link to the same repository. But the server became really slow and when I asked the head DBA why, he found a lot of SQL commands chewing CPU that all referred to #RG_ tables, which all pointed the finger at SQL Source Control. Uninstalled it from our two PCs, and the server is fast again.

Sorry fellas, this is one product we wont be using. If you can find a way of not hurting our SQL box, then tell me and I'll give it another go, but until then it's a non-starter.
harvest316
 
Posts: 1
Joined: Tue Mar 09, 2010 6:48 am


Return to SQL Source Control EAP

Who is online

Users browsing this forum: No registered users and 0 guests