Aggregate Ignored By packager

Packages and compresses schema and contents of SQL Server databases

Moderators: JonathanWatts, Chris Auckland, David Atkinson, david connell, Anu Deshpande, Michelle Taylor, james.billings, Marianne

Aggregate Ignored By packager

Postby chrisrm » Wed Jan 20, 2010 1:23 pm

I have encountered an issue with the SQL Packager. I have a .Net CLR UDA which takes in an additional parameter. The packager ignores this aggregate and omits it from the generated SQL batches for the database ugrade.

If I run the SQL code manually to create the aggregate, there is no problem and it all works. However, it would be preferable for this to work in the packager.

My create aggregate SQL is as follows:-

CREATE AGGREGATE Helper.[Concatenate](@input NVARCHAR(MAX), @separator NCHAR(1))
RETURNS NVARCHAR(MAX)
EXTERNAL NAME [MyDll].[Aggregates.Concatenate];
GO
chrisrm
 
Posts: 5
Joined: Tue Nov 03, 2009 11:06 am

Postby peter.peart » Thu Jan 21, 2010 8:03 pm

Hi Chris,

Many thanks for your post. Can you confirm if you experience this behaviour with SQL Packager 6.3?

There is a sticky detailed below with the latest patch release 6.3:

http://www.red-gate.com/messageboard/vi ... php?t=9883

Many thanks!

Pete
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
peter.peart
Site Admin
 
Posts: 362
Joined: Tue Sep 02, 2008 9:58 am
Location: Top floor, RG towers with the cool kids

Postby chrisrm » Fri Jan 22, 2010 9:37 am

Pete,

I am using version 6.3.1.7 of the packager.

Chris
chrisrm
 
Posts: 5
Joined: Tue Nov 03, 2009 11:06 am

Postby peter.peart » Fri Feb 05, 2010 2:36 pm

Hi Chris,

Thanks for letting me know. I have one of our devs looking at this now; hopefully we should be able to include a patch for this soon for you.

Pete
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
peter.peart
Site Admin
 
Posts: 362
Joined: Tue Sep 02, 2008 9:58 am
Location: Top floor, RG towers with the cool kids

Postby peter.peart » Thu Feb 18, 2010 4:31 pm

Hi Chris,

Just so you are aware, this issue has been raised under ref SPA-540. I will let you know as and when we have a fix for it.

Pete
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
peter.peart
Site Admin
 
Posts: 362
Joined: Tue Sep 02, 2008 9:58 am
Location: Top floor, RG towers with the cool kids

Postby chrisrm » Mon Jul 12, 2010 9:58 am

Any idea when this fix will be included?
chrisrm
 
Posts: 5
Joined: Tue Nov 03, 2009 11:06 am


Return to SQL Packager 6

Who is online

Users browsing this forum: No registered users and 2 guests