Error 880 permission problem with scheduled backup

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

Error 880 permission problem with scheduled backup

Postby nmalhot » Thu Jul 30, 2009 9:30 pm

Hi. Been a long time SQL Backup user ... maybe too long because having a brain fart with just basic setup:

New Windows Web Server 2008 64-Bit Server and new SQLBackup 6.1 installed.

Just want to test my installs and doing a backup on the master db from within SQL Backup works fine. Trying to make a scheduled backup within SQL Backup gives me the following error:

7/30/2009 4:20:25 PM: Backing up master (full database) to:
7/30/2009 4:20:25 PM: D:\\MSSQL\\MSSQL10.MSSQLSERVER\\MSSQL\\Backup\\FULL_(local)_master_20090730_162025.sqb

7/30/2009 4:20:26 PM: Error 880: BACKUP DATABASE permission denied in database: (master)
7/30/2009 4:20:26 PM: SQL error 15157: Setuser failed because of one of the following reasons: the database principal '28455-DB2\\MSSQL_USER' does not exist, its corresponding server principal does not have server access, this type of database principal
cannot be impersonated, or you do not have permission.

The SQL Backup Agent service is running under Administrator and when I connect to MS SQL Manager I use windows authentication and as administrator, that works fine also.

The Activity History in SQL Backup also shows Successful backups on the master db from the MS Backup plan for the same 28455-DB2\\MSSQL_USER User Name that is showing as a failure with the SQL Backup scheduled backup.

Any thoughts on what I'm doing wrong?
nmalhot
 
Posts: 2
Joined: Thu Jul 30, 2009 9:23 pm

Postby Anu Deshpande » Mon Aug 03, 2009 10:31 am

Thanks for your post and sorry that this problem has occured.

If this is a scheduled job, SQL Backup relies upon the SQL Server Agent to trigger the job. The SQL Backup Agent Server connects to the SQL Server and checks to see if the user account for the SQL Server Agent has permissions to perform the backup using the setuser command.

SQL Backup can be configured not to perform these additional security checks by adding the SkipChecks registry key, as follows:

1. Using Regedit navigate to the following Registry Folder:
HKEY_LOCAL MACHINE\\Software\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\(LOCAL) or <SQL Instance Name>

2. Create a new DWORD type registry key called SkipChecks and give this new key a data value of 1.

Once the registry key has been created, SQL Backup will skip the user right checks for backup and restore tasks.

Kindly let us know if this resolves the issue.
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Postby alikar » Tue Aug 04, 2009 6:37 am

I am running Windows 2008 Server x64, SQL Server 2008, and SQL Backup v6.1

I Added the suggested key:

[HKEY_LOCAL_MACHINE\\SOFTWARE\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\(LOCAL)]
"SkipChecks"=dword:00000001

I am still unable to execute scheduled backups with the following error message appearing for every attempted database backup in the redgate logs:

8/3/2009 7:06:39 PM: Backing up model (transaction log) to:
8/3/2009 7:06:39 PM: E:\\Microsoft SQL Server\\MSSQL10.MSSQLSERVER\\MSSQL\\Backup\\LOG_(local)_model_20090803_190639.sqb

8/3/2009 7:06:39 PM: Error 880: BACKUP DATABASE permission denied in database: (model)
8/3/2009 7:06:39 PM: SQL error 15157: Setuser failed because of one of the following reasons: the database principal 'SERVER\\MSSQLAGENT' does not exist, its corresponding server principal does not have server access, this type of database principal cannot be impersonated, or you do not have permission.


As I am sure you are aware, MSDN suggests of SQL 2008 (http://msdn.microsoft.com/en-us/library/ms186297.aspx):

SETUSER is included for backward compatibility only. SETUSER may not be supported in a future release of SQL Server. We recommend that you use EXECUTE AS instead.


The article also states:

Only use SETUSER with SQL Server users. SETUSER is not supported with Windows users.


Do I need to change my SQL Agent account to run under a SQL Server User? Do you have any other suggestions?

Thank you.
alikar
 
Posts: 2
Joined: Tue Aug 04, 2009 6:26 am

Postby Anu Deshpande » Tue Aug 04, 2009 9:37 am

I am sorry I skipped the point that it is 64-bit server, you will then need to use the following registry node:

HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\(local) or SQL Instance Name.

Create a new DWORD type key called SkipChecks and give the key a data value of 1.

Kindly let us know if this fixes the issue.
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Postby nmalhot » Tue Aug 04, 2009 9:07 pm

The registry key fixed my problem. Thanks!
nmalhot
 
Posts: 2
Joined: Thu Jul 30, 2009 9:23 pm

Postby alikar » Tue Aug 04, 2009 9:30 pm

Fixed me, too. Thank you for the quick response!
alikar
 
Posts: 2
Joined: Tue Aug 04, 2009 6:26 am

Postby Anu Deshpande » Wed Aug 05, 2009 3:23 pm

Many thanks for the confirmation.
We are pleased that your issue is resolved :)
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Postby Chris.Allen » Mon Sep 14, 2009 8:28 am

If this doens't work, I find this solves 80% of all such problems:

Run the Red Gate SQL Backup agent as Local System. Job done.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Same problem

Postby ajgonzalezm » Fri Feb 18, 2011 7:54 pm

Hi guys,

Got exactly this problem but my server doesn't have the registry key you mentioned! So, what?

Mi SQL Server machine is running on Windows Server Web Service Pack 2 and is a 64 Bit Operating System.

Please help!

Thanks in advance.

Cheers, AJ
ajgonzalezm
 
Posts: 2
Joined: Fri Feb 18, 2011 7:39 pm

Postby petey » Sat Feb 19, 2011 1:37 am

If you're using version 6.4, the 'SkipChecks' registry entry should be created in the 'HKEY_LOCAL MACHINE\\Software\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\(LOCAL) or <SQL Instance Name>' node.
Peter Yeoh
SQL Backup Consultant Developer
Associate, Yohz Software
Beyond compression - SQL Backup goodies under the hood, updated for version 7
petey
 
Posts: 2229
Joined: Sun Apr 24, 2005 12:34 pm

Postby ajgonzalezm » Tue Feb 22, 2011 12:48 am

That worked fine!

Thank you very much.

Best regards,

AJ
ajgonzalezm
 
Posts: 2
Joined: Fri Feb 18, 2011 7:39 pm

SkipChecks

Postby SQLJunkie » Thu Apr 14, 2011 9:52 pm

We are using the 6.4 version and this solution works great for us.

Cheers.
SQLJunkie
 
Posts: 1
Joined: Thu Apr 14, 2011 9:48 pm

Postby thaicla » Tue Apr 19, 2011 7:36 am

That's working great!

I tried to find this fix for a long time , ha ha.

Thanks.
thaicla
 
Posts: 1
Joined: Tue Apr 19, 2011 7:13 am

Solution works...please make it permanent

Postby drueter » Fri May 06, 2011 8:33 pm

+1 on this solution working on Server 2008 x64 / SQL 2008R2.

I would suggest that Red Gate make this the default--as I don't understand the value of the broken functionality that this registry setting disables.

At a minimum, Red Gate should move the setting from the registry to a configuration setting accessible from the application, and should provide a link or a reference from the error message to that configuration setting.
drueter
 
Posts: 2
Joined: Wed Dec 20, 2006 6:22 pm
Location: California, USA

Postby Markb » Thu Sep 15, 2011 10:44 am

I've been trying to solve this problem for a day or so now!

Come on Redgate this needs to be addressed! Wasted a lot of time thinking it was a permission issue when actually it isn't.

This registry fix resolved my problem Windows 2008 R2 Standard x64 & SQL 2008 R2 SP1.
Markb
 
Posts: 5
Joined: Tue Feb 26, 2008 2:34 pm
Location: Norfolk, United Kingdom

Next

Return to SQL Backup 6

Who is online

Users browsing this forum: No registered users and 0 guests