Crash only during Profiling

Code profiling for .NET Developers

Moderators: StephenC, Alex.Davies, AndrewH

Crash only during Profiling

Postby heyneer » Thu Jun 18, 2009 3:46 pm

Hi,

I'm new to Ants Performance Profiler.

What should I do if my application crashes (throws Exceptions) only during profiling? These exceptions are not always the same...

I don't have that problem when I run my app in VS2008 or in release. I'm working on XP 64bits.

I have the problem with the version 4, and since this morning, with the version 5.0 also...

Thank you,

Eric
heyneer
 
Posts: 1
Joined: Thu Jun 18, 2009 3:37 pm
Location: Montreal

Postby StephenC » Thu Jun 18, 2009 4:46 pm

Hi,

can you try profiling the application at the method level (instead of line level). You can choose the profiling mode from the setup dialog.

Visiting the log file directory:
C:\\Documents and Settings\\YOUR.NAME\\Local Settings\\Application Data\\Red Gate\\ANTS Performance Profiler 5
and sending us any log files (support@red-gate.com) referencing this post would also be welcome.

Lastly if you are getting any stack trace exceptions if you could let us know what exceptions are being thrown that would also be very useful. Some screen shots would be fine - although it sounds like you aren't getting any stack traces? If this is the case then a mini-dump would be useful and I can provide instructions on how to do that if needed.

Stephen
StephenC
 
Posts: 306
Joined: Mon Oct 15, 2007 9:18 am
Location: Cambridge

Postby Chris.Allen » Thu Jun 25, 2009 10:39 am

Hi there. I've got your support call now and I've been reading through the history. So- to start with, no, hopefully you didn't buy ANTS for nothing :) We do get a number of crashes-under-profiling and they happen for a variety of reasons, most of which we solve and some of which we cannot. I'll endeavour to find out which one we have here but this will need a fair bit of debugging.

Firstly, please would you set the logging to full debug mode i.e. in the file

%userprofile%\\Local Settings\\Application Data\\Red Gate\\ANTS Performance Profiler 5\\LoggingConfiguration.xml

change all the "tagged blocks" to look like the following:

<root>
<level value="DEBUG" />
<appender-ref ref="DefaultRGFile" />
</root>

<logger name="RedGate.Profiler.Engine">
<level value="DEBUG"/>
</logger>

<logger name="RedGate.Profiler.Logging">
<level value="DEBUG" />
</logger>

<logger name="RedGate.Profiler.Monitoring.PerformanceCounterFactory">
<leval value="DEBUG"/>
</logger>


(wierdly enough, you'll need to change instances of "leval" to "level" as well - sorry!)

Then please reproduce the problem and send us the resulting logfile (to support@red-gate.com).

We then may need to force and look at a dump of the crash (this is what we mean by a mini-dump- "mini" signifying that it is from the .NET runtime, I believe). We usually use windbg and I can drive this from a shared web session if you like.

But first, I think the debug logs would be a good start.

Cheers.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm


Return to ANTS Performance Profiler 5

Who is online

Users browsing this forum: No registered users and 0 guests