issue profiling IIS web site on vista

Code and memory profiling for .NET developers.

Moderators: Brian Donahue, richardjm, StephenC

issue profiling IIS web site on vista

Postby alecl » Wed May 06, 2009 8:00 pm

Code: Select all
Could not launch the task to be profiled.
RedGate.Profiler.Engine.Exceptions.CannotStartSessionException
  at bI.Launch()
  at RedGate.Profiler.Session.ProfilerSession.j()

Caused by:

Could not start IIS.
RedGate.Profiler.Engine.Exceptions.CannotStartIisSessionException
  at bO.PerformLaunch()
  at bI.Launch()

Caused by:

Ambiguous site selection. Could not determine which site should be profiled.
RedGate.Profiler.Engine.Startup.IIS.IISException
stack trace:
  at RedGate.Profiler.Engine.Startup.IIS.IISUtilities.a(Uri )
  at RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities.GetApplicationPool(Uri uri)
  at RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities.GetIISinx64(Uri url)
  at bn.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
  at RedGate.Profiler.Engine.Startup.IIS.IISStarter`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
  at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
  at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
  at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)
rethrown at [0]:
  at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
  at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
  at RedGate.Profiler.Engine.Startup.IIISActuator`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
  at bO.PerformLaunch()


My website is a subweb under the port 80 default web site.

So I put http://localhost/mysite/page.aspx and I get the issue above.
alecl
 
Posts: 16
Joined: Mon Jul 23, 2007 6:10 pm

Postby alecl » Wed May 06, 2009 10:30 pm

I found a workaround. I have multiple sites defined in IIS using virtual hosting. I added a new port to my main site and ran the profiler with that port and it worked.
alecl
 
Posts: 16
Joined: Mon Jul 23, 2007 6:10 pm

Postby Chris.Allen » Mon May 11, 2009 10:34 am

That's exactly the advice we give when faced with this error, well done.

Its a bug in ANTS- the web site is obviously not really "ambiguous" but it doesn't distinguish different web sites/same port.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm


Return to ANTS Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests