Profiling on Windows 2003 not working

Code and memory profiling for .NET developers.

Moderators: Brian Donahue, richardjm, StephenC

Profiling on Windows 2003 not working

Postby mmodra11 » Fri May 01, 2009 8:49 pm

I just got a trial of ANTS 4.3 and tried to put it on a test server - a Windows 2003 SP 2 box running IIS 6.

I tried to run up the profiler and select ASP.NET web application (hosted in IIS) but it threw up an error box saying

The version of Windows Server 2003 you have installed does not include full IIS support so you cannot profile ASP.NET applications running on IIS. We have detected that you are running {0}. Upgrade your operating system edition to enable IIS support.

Problem is that the error message doesn't say what it detected or what I need. Any pointers?

Thanks
Mark
mmodra11
 
Posts: 2
Joined: Fri May 01, 2009 8:45 pm

Postby Brian Donahue » Mon May 04, 2009 12:48 pm

Hi Mark,

ANTS Profiler will not profile web applications hosted in Windows 2003 Web Edition because that platform is singled out as unsupported in ANTS Profiler's code. After a brief look into it, we had concluded that there was no reason we could find not to support it, so the next version will work with Web Edition.

In the meantime, you can use the Development Web Server option if it is available to use.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Thanks

Postby mmodra11 » Mon May 04, 2009 3:56 pm

Hi Brian...

Thanks for the response. Unfortunately, the Dev Web Server option isn't really possible, given the number of moving parts (isapis, mapped virtual dirs, etc).

When will the newer version allowing Windows 2003 Web Edition be available? I can retry it then.

Thanks
Mark
mmodra11
 
Posts: 2
Joined: Fri May 01, 2009 8:45 pm

Postby StephenC » Mon May 04, 2009 5:00 pm

Hi there,

we are trying to get this in place for the Beta of V5 which will be available within 1 - 2 weeks. If that doesn't happen then the final release will be quite soon after that.

I'll drop a post on here when it's available.

Regards,

Stephen
StephenC
 
Posts: 306
Joined: Mon Oct 15, 2007 9:18 am
Location: Cambridge

Postby Chris.Allen » Wed May 06, 2009 1:23 pm

In the meantime, anyone having this same problem may use this earlier version of ANTS 4.

ftp://support.red-gate.com/patches/ants ... 1.0.45.exe
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm


Return to ANTS Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests