.NET app crash only during profiling

Code and memory profiling for .NET developers.

Moderators: Brian Donahue, richardjm, StephenC

.NET app crash only during profiling

Postby devdept » Mon Jan 19, 2009 3:50 pm

Hi RG,

What should I do if my app crashes only during profiling with a random exception?

I am working on a .NET 3.5 project with AnyCPU platform setting on a Vista Business x64 PC.

Thanks,

Alberto
devdept
 
Posts: 22
Joined: Mon Jan 19, 2009 3:21 pm

Postby Brian Donahue » Mon Jan 19, 2009 7:29 pm

Hi,

It's going to be difficult to give advice about random failures in the code even if it is ANTS Profiler's faul. Most commonly, there are problems with code that profuces and JITs its' own IL code because ANTS Profiler's IL rewriting is trying to do exactly the same thing. In this case, you can get method-level timings, but line-level timings would cause this type of crash.

Changing ANTS Profiler to only use method-level timings should hopefully work for you.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby devdept » Mon Jan 19, 2009 9:19 pm

Hi Brian,


No, it doesn't help and I really find it difficult to understand your explanation.


Thanks,

Alberto
devdept
 
Posts: 22
Joined: Mon Jan 19, 2009 3:21 pm

Postby Brian Donahue » Tue Jan 20, 2009 10:54 am

I'm sorry you didn't understand my post. All I am saying is basically there are some applications that will work when you profile using the "method-level timings" setting and not "line-level timings" because ANTS Profiler injects code into the application while it is running. If your application does the same thing, then it may fail. Even if you are just using third-party dlls that do this. And I'm afraid I don't know any way to detect if this is happening or know what you can do about it. Except not to use line-level timings only in the ANTS Profiler settings.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby devdept » Tue Jan 20, 2009 11:49 am

So unreferencing third party DLL may help?

Why it didn't happen on Vista Business x86?

Thanks,

Alberto
devdept
 
Posts: 22
Joined: Mon Jan 19, 2009 3:21 pm

Postby devdept » Wed Jan 21, 2009 10:49 pm

Hi Brian,


After fixing a few things the problem is not so frequent as before. I'll keep you updated.


Thanks,

Alberto
devdept
 
Posts: 22
Joined: Mon Jan 19, 2009 3:21 pm


Return to ANTS Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests