w3wp Process Crashes

Code and memory profiling for .NET developers.

Moderators: Brian Donahue, richardjm, StephenC

w3wp Process Crashes

Postby cqueenan » Wed Jan 14, 2009 1:41 pm

Hi -
I have a asp.net application running on a windows 2003 server using framework 3.5. Whenever I try to profile using "ASP.NET web Application (hosted in IIS)" my w3wp process crashes in the same place with the following:

Unable to get the private bytes memory limit for the W3WP process. The ASP.NET cache will be unable to limit its memory use, which may lead to a process restart. Error: 0x80070003

Faulting application w3wp.exe, version 6.0.3790.3959, faulting module ProfilerCore.dll, version 4.1.0.45, fault address 0x0001a9ea.

System.ArgumentException: Process with an Id of 3880 is not running.
at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)
at System.Diagnostics.Process.GetProcessById(Int32 processId)
at bt.StopProfilingIIS()

Anyone have any ideas what is wrong?

thanks
cqueenan
 
Posts: 2
Joined: Wed Jan 14, 2009 1:35 pm

Postby Brian Donahue » Fri Jan 16, 2009 2:22 pm

Hi,
What'd probably happened is that when the .NET runtime loaded the ProfilerCore dll into the w3wp process, it crashed on the call that initializes the profiling session. This could have happened for virtually any reason under the sun, but like with all things Windows I would have a look at permissions. If your app pool runs as a certain user, try matching the ANTS Memory|Performance profiler service to that user so the app pool doesn't start as SYSTEM, which would be the default.

The first error message is pretty meaningless and always occurs when you try to run w3wp.exe in debug mode like ANTS Profiler does. Anyway, the fact that ASP .NET will not be doing any process recycling is a good thing in my book!
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby cqueenan » Fri Jan 16, 2009 3:01 pm

I'm not sure it is a permission thing. What I just tried was the following

1. Create a new applicaiton pool which is running under a Local Admin ID
2. Pointed the virtual directory to that applicaiton pool
3. Went into servies and changed ANTS Memory Profiler 4 Service and ANTS Performance Profiler 4 Service to use the same Local admin ID in step one.
4. Restart IIS, and the 2 services.

When I look in task manager all 3 processes are running under the same ID, but I still crash at the same place.

Any other Ideas?

thanks!
cqueenan
 
Posts: 2
Joined: Wed Jan 14, 2009 1:35 pm

Postby Brian Donahue » Fri Jan 16, 2009 3:47 pm

It sounds like the core is crashing out, but since it's unmanaged code there will be no stack trace pointing out the error... just the offset information and I've been told that we can't work out exactly where in the code this crash happens based on that.

Best I can suggest is to get a copy of the Profiler log in %USERPROFILE%\\Local Settings\\Application Data\\Red Gate\\ANTS Performance Profiler 4 and send it to support@red-gate.com.

If any entries are created by Profiler core at least we know that it initialized.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Profiler Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests