Using SQL Packager 5 - fails immediately - no dialog box

Packages and compresses schema and contents of SQL Server databases

Moderators: JonathanWatts, Chris Auckland, David Atkinson, david connell, Anu Deshpande, Michelle Taylor, james.billings, Marianne

Using SQL Packager 5 - fails immediately - no dialog box

Postby Sue_W » Thu Jan 08, 2009 11:28 pm

Hi,

We are trying to run our database redgate sql package directly on client computer and the redgate package application fails immediately - does not even give the dialog box that shows 'local', etc.

The client is running Windows Vista with SQL Server Express 2005. There are 2 instances on the computer as well.

We tried running the package directly after our install wrapper also failed with an error in the Windows Event log referencing 'SQLTestConnection.exe' failed.

The redgate packager error in Windows Event log was:

General

Faulting application SQLPackageFull_v151_29.exe, version 1.0.3237.29324, time stamp 0x491a0479, faulting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000005, fault offset 0x0022ec4c, process id 0x10cc, application start time 0x01c971d94bea66a8.

+ System

- Provider

[ Name] Application Error

- EventID 1000

[ Qualifiers] 0

Level 2

Task 100

Keywords 0x80000000000000

- TimeCreated

[ SystemTime] 2009-01-08T21:37:25.000Z

EventRecordID 5922

Channel Application

Computer OCST

Security


- EventData

SQLPackageFull_v151_29.exe
1.0.3237.29324
491a0479
unknown

Does anyone have an idea why the packager is failing or our wrapper is failing? Is there a quick fix? We can access the database instance through windows and sql auth using SQL Management Studios but cannot connect via either our installer wrapper or red-gate packager. We believe the problem is tied to the SQLTestConnection.exe but we don't know for sure. Where is the SQLTestConnection.exe being called from? By OS or SQL? Can someone explain more about SQLTestConnection?

Any information will be appreciated. Thanks!
Sue_W
 
Posts: 4
Joined: Mon Feb 04, 2008 11:25 pm

Postby Matthew Flatt » Mon Jan 12, 2009 7:01 pm

Hi Sue,

Could you please download a little command line app from Here.

Extract it on the machine which you are trying to run the package and call it from the command line.

Do you get a list of available instances or is an error message displayed?
Matthew Flatt
Test Engineer, HyperBac
Matthew Flatt
 
Posts: 253
Joined: Tue Jan 15, 2008 4:45 pm

Postby Sue_W » Mon Jan 12, 2009 8:38 pm

Hi Matthew,

We figured out the issue late last Friday. We were able to narrow the issue down to the framework by proving we could connect and test a 'new data source' using the 'data source' program in Windows. It worked fine. We concluded it must be the framework so we ran a framework repair program. Our install wrapper and Redgate Packager worked fine after we repaired the framework.

Thanks,
Sue
Sue_W
 
Posts: 4
Joined: Mon Feb 04, 2008 11:25 pm


Return to SQL Packager 6

Who is online

Users browsing this forum: No registered users and 0 guests