Dependency Problems

Forum for users of SQL Packager database archive utility

Moderator: David Atkinson

Dependency Problems

Postby miro » Thu Sep 06, 2007 6:58 pm

Hi,

I'm just trying to create a structure only copy of my database, but when I try to execute the packager file, I get errors when the package attempts to create a view (Invalid object name [TableName]). In looking at the generated scripts, it appears that the view is being created before the tables, which obviously isn't going to work.

I am a first-time user, so I don't think I have set any options differently or changed anything about the prgram (not intentionally). I can't find any options to control the order of execution, but I can't seem to be able to get a simple pass to work properly... any thoughts would be greatly appreciated.
miro
 
Posts: 3
Joined: Thu Sep 06, 2007 6:45 pm
Location: Charlotte, NC

Postby Brian Donahue » Fri Sep 07, 2007 9:15 am

Thanks for asking. Is this a new database package or an upgrade package?
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby miro » Fri Sep 07, 2007 5:44 pm

This is a new package... I'm just trying to do structure only, no data.
miro
 
Posts: 3
Joined: Thu Sep 06, 2007 6:45 pm
Location: Charlotte, NC

Postby Brian Donahue » Fri Sep 07, 2007 5:46 pm

Where TableName appears in the view, is the object fully-qualified? If it contains the name of the database, it may not be being picked up as a dependency. For instance MyDB.DBO.TableName.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby jimboh » Thu Sep 27, 2007 1:06 pm

suggest you may have a collation or case sensitivity issue
jimboh
 
Posts: 17
Joined: Mon Jan 29, 2007 12:23 pm
Location: Melbourne Australia

Re:

Postby miro » Tue Nov 06, 2007 7:39 pm

Brian Donahue wrote:Where TableName appears in the view, is the object fully-qualified? If it contains the name of the database, it may not be being picked up as a dependency. For instance MyDB.DBO.TableName.

No, in the specific example I am looking at the view is referencing just the table name, with no owner or database name specified. Is this the issue?
miro
 
Posts: 3
Joined: Thu Sep 06, 2007 6:45 pm
Location: Charlotte, NC

Postby Brian Donahue » Wed Nov 07, 2007 10:05 am

I don't think that would cause a problem to exclude the owner name as far as the dependencies go.

I don't know what is happening here. I think it would be necessary to see the SQL scripts for these two objects.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to SQL Packager Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests