Internal server error due to event validation

Forum for users of ANTS web server load testing tool

Moderator: Brian Donahue

Internal server error due to event validation

Postby pwrcut » Tue Jan 16, 2007 6:11 am

The website I am testing using ANTSLoad performs as expected while recording a script, but not while running the script, presumably because of aninternal server error (500) that, in part, reads:

Item http://financialsoundings.com/softlaunch/Default.aspx ASP.NET HTML content <html> <head> <title>Invalid postback or callback argument. &nbsp;Event validation is enabled using &lt;pages enableEventValidation=&quot;true&quot;/&gt; in configuration or &lt;%@ Page EnableEventValidation=&quot;true&quot; %&gt; in a page.

What is the best way to handle this?

Also, I cannot test more than 5 virtual clients, because apparently I have a serial no. but no .lic file. How do I get it?

Thanks
pwrcut
 
Posts: 1
Joined: Tue Jan 16, 2007 5:39 am
Location: USA

Postby Brian Donahue » Tue Jan 16, 2007 7:44 pm

Hello,

Thanks for writing. You will need to contact sales@red-gate.com and request a licence file. Please provide your serial number and they shouldn't have a problem creating a new licence for you.

Given the nature of the error message, I'd suggest upgrading to the latest version of ANTS Load. As of version 1.7, it handles the eventvalidation dynamically in much the same way as it does viewstate. Therefore, I'd assume that you either have an older version of ANTS Load or a script created in a version of ANTS before it supported Eventvalidation.

If you need anything more, please let me know.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Load

Who is online

Users browsing this forum: No registered users and 0 guests

cron