Searching problems

Forum for users of Aardvark bug tracking system

Moderator: Brian Donahue

Searching problems

Postby rbailey » Thu Aug 17, 2006 2:55 pm

Hi,

I am having a problem using the search for issues by date.

No matter what combination of date format or separators I try, it either returns no results at all or what appears to be every result.

The "or in the last n days" option always states no matching results found.
This is something that has never worked for us, and is becoming more and more of a problem as the number of bugs stored increases.

Does anyone know how to solve this issue please?

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Tue Aug 22, 2006 8:57 pm

Hi Richard,

I suspect that the SQL Server's full-text catalogs may be to blame there, since the searches use FTX queries. You can try rebuilding the catalog by locating it in the Aardvark database (in Enterprise Manager). Right-click each of the three full-text catalogs and select 'Rebuild', then 'Start full population'. Once that's done, check the SQL Server Agent under Management, and make sure there is an Aardvark job for full-text incremental population. Make sure that job has no errors in its' history, that it will run successfully by right-clicking it and selecting 'run now', and that it has a valid schedule.

If the jobs don't exist at all, open the Aardvark program folder, open the SQL subfolder, and run jobs.sql to create the Aardvark jobs on the server.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

No luck

Postby rbailey » Wed Aug 23, 2006 10:25 am

Hi Brian,

I rebuilt the catalogs and repopulated them, but the problem still remains.
The job is all present and correct also. There doesn't appear to be any errors in the history either.

Any more suggestions?

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Wed Aug 23, 2006 12:37 pm

What version? It may have been a bug that got fixed.

The whole search mechanism depends on fulltext so I have no clue what else it could be.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Version information

Postby rbailey » Wed Aug 23, 2006 12:56 pm

Aardvark is version 2.00, with the database version 2.00.

Aardvark is installed on Windows Server 2003 SP1.
The SQL server is running on a separate server.
SQL Sever Standard Edition 2000 SP3.

Is it possible the database could have become damaged?
Do you think something like creating a backup to an XML file, creating a new database and importing the data back in could help?
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

bugsschema2.xml?

Postby rbailey » Wed Aug 23, 2006 6:19 pm

I just noticed that I can't open any of our backed up XML data because the schema file is not available.

http://apps.red-gate.com/schema/bugsschema2.xml

Can I get a copy of this file from somewhere?

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

XML Schema

Postby rbailey » Fri Aug 25, 2006 10:49 am

Hi Brian,

Is there any news on the availability of the above schema file?

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Fri Aug 25, 2006 12:42 pm

Hi Richard,

Sorry, but we don't have a copy of it any more since Aardvark's been discontinued. The apps server has been decommissioned long ago and I suspect this file has died with it. It's not with the original source code, either.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to Aardvark

Who is online

Users browsing this forum: No registered users and 0 guests

cron