not recording in popup window?

Forum for users of ANTS web server load testing tool

Moderator: Brian Donahue

not recording in popup window?

Postby kpeter » Wed Aug 02, 2006 7:11 am

Hi,

I am trying to record a testcase which has the following stages:
load index page
log in with name/pwd
check user data
click on a button, which throws a popup window which communicates with a web service in XML.

As I see, the Ants load does not record anything from the part which happens in the popup window. Nor the page loading itself, nor the xml communication generated are observed.

Is there any workaround?
regs,
Peter
kpeter
 
Posts: 2
Joined: Wed Aug 02, 2006 7:06 am

Postby Brian Donahue » Wed Aug 02, 2006 6:14 pm

Hello Peter,

If the window is being launched a certain way in a JavaScript, and this doesn't trigger Internet Explorer's OnNavigate event handler, then the navigation doesn't appear in the script. I still don't know exactly what kinds of navigation don't trigger onNavigate; I suspect Window.Open().

You may need to resort to simulating these requests by manually scripting the WebClient.GET(url) commands in the test script.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby kpeter » Thu Aug 03, 2006 6:39 am

Hello Brian,

Yes, you are right: the popup is opened thru a custom javascript function which actually does its job by window.open.
Thanks,
Peter
kpeter
 
Posts: 2
Joined: Wed Aug 02, 2006 7:06 am


Return to ANTS Load

Who is online

Users browsing this forum: No registered users and 1 guest